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Abstract 
This report presents the Caltrans Workflow for Virtual Geomatics (VG4D). Virtual 

Geomatics is a powerful and efficient point cloud processing engine designed to handle large 
datasets (billions of points). The application’s complete end‐to‐end workflow includes automatic 
classification, smart feature extraction, automatic digitization, batch processing, asset 
management, project management/tracking, and report /deliverable generation. This report 
includes step-by-step workflow for Virtual Geomatics using Caltrans data and examples. 
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Chapter 1: Introduction 
 

VG4D Smart LiDAR Analyzer Pro, the flagship product of the SmartLiDARTM solutions, is one of 

the most comprehensive and flexible solution available today.  The robust features include 

customized application‐oriented workflow for airborne, mobile, corridor and static LiDAR/point 

cloud datasets. Built to fully exploit LiDAR point cloud data to its fullest, the standards‐based 

solution features a powerful and efficient point cloud processing engine designed to handle 

large datasets (billions of points). The application’s complete end‐to‐end workflow includes 

automatic classification, smart feature extraction, automatic digitization, batch processing, 

asset management, project management/tracking, report /deliverable generation and much 

more.   

VG4D is one of several programs we have evaluated. Others include InnovMETRIC’s PolyWorks, 

Leica’s Cyclone, Trimble’s Realworks Survey, and MicroSurvey’s PointCloud CAD. These will be 

documented based on available resources. 

 

Highlights of VG4D include: 

• End‐to‐end LiDAR processing in a stand‐alone solution; requiring no additional 3rd party 

software 

• Efficient "point cloud" LiDAR Engine capable of handling very large datasets 

• Powerful and user‐friendly 3D visualization with many "easy‐to‐use, one‐click" 

capabilities 

• Versatile data export capabilities coupled with real‐time tracking and reporting 

• Comprehensive deliverables for all industry‐recognized engineering applications 

• Integrates seamlessly with other VG4D SmartLiDAR applications to lower cost of 

ownership 

Let’s have a quick look at how the workflow for the software looks like and it would be 

discussed in details in subsequent chapters in the report. 
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OVERVIEW OF WORKFLOW  
 

Tile LayoutImportingAnalyzer

Feature 
Extraction

Export

MacrosViewer

Asset 
Management

Batch 
Filtering of 
LAS filesProject 

Management

Data QA/QC

Report 
Generation

 

Figure 1: Workflow for VG4D 

The software has two modules: Analyzer and Viewer. One may directly open the files in Viewer 

but the files would not be saved. Also some important functions like Feature Extractions cannot 

be executed if the file is not opened via the Analyzer.    

File System of VG4D: VG4D recognizes two main types of files: 

• LAS File: A public file format for the interchange of LIDAR data between vendors and 

customers. For more information, please refer: 

http://www.asprs.org/a/society/committees/lidar/lidar format.html 

• Shape file: This file format describes geometries: points, polylines and polygons. Each 

item could also have attributes that describes the items, such as name. For more 

information please refer: 

http://en.wikipedia.org/wiki/Shapefile#Shapefile shape format .28.shp.29 
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LiDAR Analyzer 
The LiDAR Analyzer is the interface where the VGP Projects are created and maintained. In this 
window we have a standard toolbar and LiDAR Analyzer Toolbar.  
The user will be able to view only in 2 dimensions (in X, Y); shape files of all the LAS files 
imported are created to give the user an overview of the project bounds. The LiDAR Analyzer 
has many tools for performing batch processes, generating reports, performing manual checks 
and feature extraction, extracting LAS file information, invoking the 3D viewer, creating 
deliverables and many more. Each of these tools will be discussed in detail and the steps to use 
them. 

STARTING VG4D: 
• Click on the LiDAR Analyzer Pro Icon. A window opens as shown below: 

LiDAR Analyzer 
Toolbar

 

Figure 2: Window of LiDAR Analyzer 

The Workflow has 4 main parts: 
• Data QA/QC 
• Importing 
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•  LiDAR Viewer 
• Project Management 

Each of these workflows has several sub-processes which would be described in this report.  
 
Let’s have a quick look at the Analyzer and its toolbar.  

• To start LiDAR Analyzer left-click on LiDAR Analyzer Pro Icon on your desktop. 

LiDAR Analyzer Toolbar 
 

 
Figure 3: Toolbar of LiDAR Analyzer 

 - Open View: - For opening a saved view of the project 
 - Save View – Saves current view settings so they can be opened again. The software will 

automatically prompt the user to save the view when the software is shut down 
 - Find  
 - Full Extent – Zooms view out ot the full project’s extent 
 - Layer Extent – Zooms view to the full extent of the selected layer 
 - Add New Layer – Add additional shape files or image files to the project background 

 - Zoom in – Click and drag a rectangle to zoom into, or click and zoom into the location of 
the mouse 

 - Zoom out -  Click and zoom out from the location of the mouse 

 - Pan – Click and drag mouse to pan map view 
 - Pointer 
 - Identity – Click on a tile boundary, flight line boundary or any other polygon and view 

specific information 
 - Spatial Select – Click and drag to select multiple objects or click individual objects to select 

 - Distance Measuring Tool/Ruler 

 - Graphics Tool – For drawing polygons 

 - Invoke VG4D – Viewer by Rectangle – Click and drag to draw a rectangle of area of interet 
to be viewed in the 3D viewer. No editing or filtering functions will be available 

 - Invoke VG4D – Viewer by Tile – Select a tile to view point cloud in the 3D viewer. The tile 
will be opened in the 3D Viewer with filtering and editing functions 
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Chapter 2: Importing Files and Project 
Management 

Starting a Project 
• Click on Open Project 

 
Figure 4: Select Project Window 

• A pop up window opens showing list of existing projects in the default folder.  
• A new project can be create using Open or Create New Project 
• A project would have an extension .VGP  

ImportingAnalyzer

Viewer

Project 
Management

 

Figure 5: Workflow Progress 
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Project Settings 
 

 
Figure 6: Project Settings Window 

The project settings have 4 tabs: Classification, Status Update Information, General, and 
Advanced Information tab. 
General Tab: This tab is used for assigning project number, project name, and units to the 
project.  
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Figure 7: General Tab Option 

Classification Tab: This is used for including the Feature codes for all the various features like 
vegetation, buildings, water and so on. One may also define custom Class Features and import 
the file as a .txt file.  

 
Figure 8: Classification Tab having a custom defined class list 
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Status Update Information: This is used for assigning ID’s to various Status updates 

 
Figure 9: Status Update Information Tab in Project Settings 

Advanced Information: This tab is used for specifying project details like project manager, 
accuracy, metadata, contours, project type, and project duration.  The project type can also be 
changed using this tab. 

 
Figure 10: Advance Information Tab 
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Importing a Line-Strip Bounds or an LAS file 
• The user can import the LAS files using the Import Line-Strip Bounds tool and the 

software creates a boundary shape file that wraps around the imported LAS files 

 

Figure 11: Importing Line Strip 

•  After importing the Line-Strips, the Layer can be right clicked on, select Open Attribute 
Table and LAS file attribute can be viewed 

 
Figure 12: Attribute of Imported file 
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• Once the strip is imported, make sure to check the box on the left side and make it 
active layer as shown below.  

 
Figure 13: Active layers in Analyzer 

NOTE: If the strip is not selected, it would not be visible. If the strip name is not clicked/made 
active, it cannot be opened in the viewer. Hence make sure to check the strip for visibility and 
make it active by clicking on it.  

• Addition of layers or more strips can be done by clicking on Layers ->Add layers. 
Similarly removing of strips can be done by selecting them and clicking on Layers -> 
Remove Active Layer 

Tile Layout Tool 

Tile LayoutImportingAnalyzer

 

Tile Layout Tool is required when dealing with large size LAS file. It enables the project manager 
to deal with the required section of a big scan file. Further, the macros (which will be described 
in next chapter) can be used to run on a small tile and further extended to the entire LAS file 
which requires less time and hardware.  

• Select Ground LIDAR Workflow and click on create Tile Layout 

 

Figure 14: Create Tile Layout 
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• A window opens on selecting Create Tile Layout as shown below: 

 

Figure 15: Tile creation toolbox 

• The Width and Height of tile can be changed. Check the box ‘Round to Nearest Width 
and Height’ if nicely evened coordinates are desired 

• Change Tile color as required 
• Name the tiles alphanumerically (ex A1, A2, A3…B1) or Numerically (ex 1_1, 1_2, 1_3, 

2_1, 2_2  ...) 
• After the tiles are created the analyzer would display a window as shown in Figure 16 
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Figure 16: Created tiles as a separate layer 

• After the creation of tiles, it is required to associate the tiles with LAS file. For this, 
Select Ground LiDAR workflow-> Add Tile Data  and specify the path of the same LAS file 
for which tiles are to be created. Note that the output folder for the tiles, the shape file, 
project file as well as the LAS file should be in same folder in order to avoid the 
mismatch of file paths.  

 

Figure 17: Linking Tiles to Data 

• Once the files are associated with the tiles, make the tile layer active and click on  to 
select any tile and open its corresponding LAS file in Viewer 

NOTE: In case there is a gap between the flightlines of a single project, it may be helpful to 
create empty tiles between the gaps in data. One may also Import a Tile Layout (requires a 
shape file) or Create a Tile Layout which is very useful in not creating tiles with little or no 
data (Refer to figure 18) 

Before we move on to other parts of the workflow, it is important to learn the various 
Analysis Tools in Analyzer. 
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Figure 18: Custom Tile creation in Analyzer 

LAS Information Viewer 
 This tool reads the LAS header and displays general information about the LAS file.  

• Click on Tools in the Menu bar and select LAS information viewer 
• Specify the path of the required LAS file. A table opens which has 3 tabs: Header 

Information, Statistical Information, and Projection Information.  These tabs give 
information pertaining to the LAS file like Minimum and Maximum values of X, Y, Z, 
Intensity, Projection Type and GPS time which turns out to be useful in project 
management for large size LAS files involving multiple strips. If the points are classified it 
would also display the percentage of ground and vegetation which would be seen in the 
form of pie chart in Class Distribution 
 

 

Figure 19: Analysis Tools in Menu bar 

• This data can also be exported as a text file 

  

Copyright 2012, AHMCT Research Center, UC Davis



24 
 

 

Figure 20: Displaying LAS information 

Control Point LAS Extraction 
 The Control point extraction tool will create a small LAS file with each control point, from the 
provided control point file, embedded into it. The control point file must be in Point ID, X, Y, Z 
format with either space or comma delimiters. The LAS file then can be opened in the 3D 
Viewer and the location of the control point relative to the point cloud data can be inspected. 
The buffer distance is the size of the LAS file created. 
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Figure 21: Control point extraction 

• Click on Menu bar -> Tools -> Control Point LAS Extraction. Specify the path of LAS file 
along with the path of Control Point file location, buffer distance and delimiter.  

Determine LAS Direction 
 Select flightline LAS files and this tool will determine the flightline direction and export that 
information to a text file. 

• From the menu bar, choose Tools -> Analysis Tools -> Determine LAS Direction as seen 
below: 

 

Figure 22: Finding LAS Direction 
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• A dialog box opens as seen below. Specify the path of LAS file and Output file (as .txt 
file) 

 

Figure 23: LAS Direction finder 

Calculate Z Statistics 
 This is used for finding out the Z statistics (Overall Min. and Max. values) for a particular class 
or complete LAS file.  

• Select Tools ->Analysis Tools -> Calculate Z statistics 
• A dialog box opens as seen below: 

 

           Figure 24: Toolbox for Calculating z stats 

• Specify the Path of LAS file, the input classes and click on Calculate to view the Z stats. 
The differential dZ can also be viewed by same method.  

• The results can be exported as a text file by clicking on Export Report 
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Calculate Point Density 
This is used for calculating point density.  

• Select Tools ->Analysis Tools ->Calculate Point Density. A dialog box appears as shown 
below: 

 

Figure 25: Calculation of Point Density 

• One may also select a particular class for which the point density is required to be 
calculated.  

• The point density can be exported as a text report with the displayed information above 
by clicking on Export Report  

LAS Statistics 
This is used for calculating the complete statistics of the LAS files like minimum X, Y, and Z 

• Select Tools ->Analysis Tools ->Generate LAS Statistics.  A dialog box opens as shown in 
Figure 26 
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Figure 26: Generation of LAS Statistics 

• Specify the path of LAS file and output file name.  

Cross Section Extraction 
This tool is used for creating cross section using LiDAR Analyzer 

• Select Tools ->Analysis Tools ->Cross-section Extraction.  Specify the width and length of 
Polygon Strip size in the dialog box as shown below.  

• One may also draw a line along which cross sections are desired by clicking Draw line 
and drawing the line in Analyzer over the strip 

 

Figure 27: Cross section extraction 

• After drawing a line the cross section as visible in the strip is shown below: 

 

Figure 28: Created Cross Section as seen in Analyzer 

• After creating the lines, you may want to specify the name of the shape file for saving 
the cross section 
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• The cross-section would be visible as a separate layer in the Analyzer as shown below 

 

Figure 29: Cross section layer in Analyzer 

Export to KML with Image 
 This is used to for exporting an image file as a KML in Google Earth.  

• Select Tools ->Analysis Tools ->Export to KML with Image 

 

Figure 30: Export to KML toolbox 

• The user must have the survey index file and image folder to be specified for using this 
command which are to be specified in the dialog box along with the output folder and 
image requirement. The image width and height can be selected from standard sizes: 
320×200, 640×480, 720×348, 1024×768, 1280×1024, 1366×768, 1600×1200, and 
1920×1200 

  

Copyright 2012, AHMCT Research Center, UC Davis



30 
 

Chapter 3: LiDAR Viewer 

ImportingAnalyzer

Viewer

 

VG4D has a free, easy-to-use, 3D, fully interactive, LiDAR viewing tool which is capable of 
various features as described in this tutorial.  The main features of this are: 

• Powerful and easy-to-use 3D data viewer 
   Rapidly visualize point cloud data for display 
   Profile / cross-section view 
   One-button classification visualization 
   Visualization modes include: 
        - Shaded relief  
        - Elevation  
        - Return 
        - Intensity shading 
        - Color by classification 
        - Color by flight line 
        - Pseudo contours 
        - LSF - LiDAR Spectral Fusion 

• Intuitive 3D rotation 
        - Panning 
        - Zoom 
        - Vertical exaggeration 
        - Azimuth 

• On-the-fly TIN rendering    
• On-the-fly 3D contour visualization    
• GPS time, coordinate, return, intensity and filename readout by cursor location 
•  Stand-alone; no 3rd party software required 
•  Save high resolution screen shots 
• LAS 1.1 and 1.2 compliant 
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Starting 3D Viewer 
Invoke VG4D- Viewer by Tile – Select a tile to view point cloud in the 3D viewer. The tile will be 
opened in the 3D viewer with filtering and editing functions depending on the tile status in the 
project lifecycle/workflow.  

If enabled, the Open Independent Viewer icon  will be present in the 2D Viewer’s Menu Bar 
that will allow the user open an independent viewer. The user will have to browse for LAS files 
to open and this viewer will have filtering or editing functions available but the status of that 
tile will not be tracked. If not enabled, it can be done by: 

• Click on the Tools -> Options in the Analyzer Menu Bar 

 

Figure 31: Enabling Independent Viewer Launch 

• Select Display Options Tab and Check on Enable independent viewer launch 

3D Viewer Menu Bar 
The Options in the Menu Bar are File, QC Redlining and Help. The file tab has the following 
options each of which is described as below: 
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Figure 32: 3D viewer Menu bar 

Open: Browse and select any LAS file to open 

Export ASCII: Export the currently viewed points to an ASCII file. Useful for exporting small areas 

Export LAS: Export the currently viewed points to an LAS file 

Save Screenshot: Save a high resolution screen shot of the data zoomed into in the view as a .tif 
file 

Show Status Window: Calculates the file summary like Total number of points, Range of X, Y and 
Z. This can be further exported to a .txt file by clicking on the Export Status button in the Status 
Dialog. 

 

Figure 33: Status Window 
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Show Point Selection Display Window: 

 

Figure 34: Point Selection Window 

This window has several options which are described as follows: 

• Marker Size (X): For controlling the size of marker used for selection of points 
• The points selected can be edited using Edit Selected command. Similarly Delete 

Selected can be used for deleting the selected points 
• One may also export points as .pts file using Export Points command. Similarly importing 

of points is done by Import Points and specifying the path of .pts file 

Preferences 
The Preferences window has several options. Most common ones are described below. 

Point Size: For adjusting the point size for the viewed points cloud. This can be adjusted using 
the slider bar 
Background: The background can be adjusted along the grayscale from Black to White using the 
Slider  
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Figure 35: Preferences Option in Viewer 

Grayscale: Toggle to change viewed point to grayscale. This is required in order to view shaded 
relief in grayscale. To enable it select Grayscale and Click OK 
 
Equalize: Equalizes the spectral ranges in the LSF data. Please refer to the manual for more 
details 
 
Normalize Z to Mask Noise: Masks the outlier elevation points when viewing point data 
allowing for a uniform view across a project. This option is widely used in ground LiDAR for 
extraction of ground surface. 
 
Classes to Display: For selecting the Classes to be displayed 
 
Show Other Classes as white: Classes that are turned off can be displayed whites. Select if white 
colored turned off points are desired. Selection can be done by clicking on the check box in 
Classes to display option. 
 
Returns to Display: Selecting the points to be displayed depending upon their returns which are 
Single Returns, First Returns and/or Last Returns  
 
Contour Interval: This identifies the interval for both displayed Pseudo Contours and Contours. 
Select the desired contour interval and color scheme 

Profile Window Width: The Width of the profile window can be changed here after it is drawn 
manually by selecting the desired profile window width 
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Figure 36: Profile Box (Green) as seen in Viewer 

Restrict Display to profile box only: This option is to instruct profile viewer to display only the 
data that falls within the drawn profile window or display more data to fill the profile viewer 
screen. This is used especially when drawing a very small profile window and gives user option 
to see how much data they want to view 

QC Redlining 
This function is used for QC process. A shape file can be created or opened in the 3D viewer and 
problem areas can be identified spatially by drawing polygons. Remarks can be entered too if 
needed. The user can then open the redline shape file in the 3D viewer and drive to the areas in 
question and make the required fixes. 

 

Figure 37: QC Redlining Pull down Menu 

The procedure for the same is as follows: 

• Go to QC Redlining -> Create new Redline file  
• Name and Create a new Redline shape file, or open an existing redline file by going to 

QC Redlining -> Open existing Redline file  
• In the 3D Viewer, select the Enter Redlining Mode button  
• Draw a polygon around the points in question, double clicking to end the polygon 
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Figure 38: Polygon Drawn for Comment 

• Enter comments into the text box (See Figure) and click OK 

 
• Users can press Cancel to ignore or undo currently drawn shape  
• The dropdown arrow will show a list of commonly used comments. However you may 

enter your own comments 

3D Viewer Toolbar 
 

 
 

Figure 39: 3D viewer toolbar 

The various icons in the toolbar are described as below: 

  :  Align to top view  

  : Select polygon sub-area 

 : Zoom In 

 : Zoom out 

 : Pan Left 

 : Pan Up 

 : Pan Down 

 : Pan Right 
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 : View by elevation 

 : View by Class (only if LAS data is classified) 
 : View by Return 

 : View by File (This function will color by file ID) 

 : View by Intensity Image 

 : View by LSF 

 : View by Shaded Relief 

: View Pseudo Contours – Color modulated by elevation interval 

 : View Buffers (Used only if buffers were created for tile data) 

: Reclassify LSF  

: TIN (Turns on the on-the fly TIN rendering) 

: View Contours (on-the-fly contour rendering) 

: Normal Viewing Mode 

: Manual Edit Mode 

: Select Polygon subarea to Filter- Creates an area to contain filtering activities for testing 
filters. Single left mouse click to draw polygon double left mouse click to end polygon 

: Ruler- Right Click and drag. Watch the lower left corner of the 3D Viewer status bar for the 
distance and elevation difference 

: Profile Mode – Opens Profile viewer for viewing and editing 

: QC Redlining Mode (for enabling the QC redlining function) 

 : Select Classes – Opens the Select Classes Window 

 : On-the-fly Settings – Opens the On-The-Fly Settings window. Azimuth, Elevation, and Z 
Exaggeration (Hot Keys also available) slider bars and options for moving the profile box in the 
main viewer during profile mode 

 
Figure 40: On the Fly Settings Window 
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Chapter 4: Macros and Filters 

Analyzer

MacrosViewer

Batch 
Filtering of 
LAS files  

VG4D Production Manager Filters 
The VG4D Production Manager software is equipped with fully customizable filters. Simply 
select the filter and click Run Selected Filter to open the filter and set its parameters. The filters 
are generally listed in the order they would typically be used within a Macro. To learn how to 
create Filter Macros, refer next section. 
 

 
Figure 41: 3D Viewer Filter Toolbar 

Filters in VG4D Viewer 

Reclassify Points 
This filter is used to change the classification of points. It is a good practice to run this filter first 
in a filter macro to make sure all points have been classified to the same class.  
 
Parameter Defined How to Use 
Input class The class or classes to be 

reclassified 
Select the classes that need to 
be reclassified 

Output Class The class that reclassified 
points will be assigned 

Select the class that the 
points will be reclassified to 

The first step before implementing any filter would always be reclassifying all the points to a 
common class 

• Select All Reclassify Points from List of Filters and Click on Run Selected filter in the 
LiDAR viewer. A dialog box opens as shown below: 
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Figure 42: Reclassify Points using Filters 

• Click on Select All and specify the name of the desired output class. In this Ground class 
is chosen but it is completely dependent on the user 

• Click on  icon. A dialog box appears as shown in figure below 
• Click on the class which was specified as output class 

• Select the   icon to view the points by classification 

 
Figure 43: Classification Selection Tool 

• The selected class (which is unclassified ground class in this case) will appear as seen in 
the figure below: 
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Figure 44: Point cloud classified to a ground class 

Ground Filter 
This filter is designed to be an easy to use filter for finding ground. It works on all terrain types 
and low and high points are also automatically filtered out.  

• Click on the Airborne : Ground Filter 
• Select the aggressiveness of the point filtration. The more aggressive, the more accurate 

is the filtration process but it takes time  
• Select the appropriate Data type, Units of the data and terrain type 
• Input Class identifies the class or classes where the points needed to perform the 

classification currently exist 
• Select the class where the Non-ground Points will be moved to 
• Select the class name to assign to the points that meet the ground criteria.  It is 

recommended to use the class ground for this  
• The option Building Size is only used to identify points that are particular structures or 

bridge columns.  Min Z Threshold is also an advanced parameter which is used to specify 
the Z threshold based on elevation resolution of the data to gather valid ground points. 
It is available if Manual if selected. Similarly Max Z Threshold is based on elevation 
resolution of the data to identify non-ground points.  
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Figure 45: Ground Filter 

• After using this filter, click on Selection tool to select just the Ground class with just the 
ground surface!  

 

 
Figure 46: LAS file with ground filter implementation 
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Mobile Road Surface Extraction Filter 
This filter is used for extracting the road surface with all the features like lane line and curb line.  

• Select Mobile Road Surface Extraction Filter from the list of filters 
• Select the Aggressiveness required along with the units 
• Specify the Input Class (which would be ground class in this case) and the class to which 

the Non-Road Surface Points will be moved to 
• Click on Ok. Select Classification Tool and highlight the Ground Class from the list to 

view just the road surface 

 
Figure 47: Filter for Road Surface Extraction 

• If you select the All classes option and color points by classification from the toolbar, 
you may now see the classified road surface 
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Figure 48: Road surface after classification 

NOTE: If a filter is run and the results are undesirable, click Undo Last Filter Step in the Filter 
Toolbar  

Other Filters 
There are other filters also besides the one described above. The user is requested to read the 
manual for further explanation. 

• Vegetation Filter: This filter classifies LiDAR points by analyzing the elevation differences 
between neighboring points. Best used as a vegetation filter. Can also be used for 
classifying isolated points 

• Advanced Vegetation Filter:  This filter classifies LiDAR points by analyzing the minimum 
and maximum elevation differences between neighboring points. Works similar to the 
Vegetation filter. Instead of a static number of neighbors and a minimum elevation, this 
filter allows you to define a range of neighbors and elevation differences. Best used as a 
vegetation filter 

• Surface Fit Filter: This filter classifies LiDAR points by analyzing the surface fit within the 
search area based on the elevation difference condition. This filter works well for rolling 
terrain. It can be used to classify buildings left behind after classifying vegetation. This 
filter might take away points from hills into hilltops in rolling terrain if the search size is 
too large and is good for final surface cleanup 

• Building Clean-up Filter: This filter classifies LiDAR points by comparing the elevation 
difference between two classes  

• Classify Spatially Close Points Filter: This filter classifies LiDAR points by analyzing the 
spatial ‘closeness’ of points within a minimum distance 
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• Multiple Return Analysis Filter: This filter classifies LiDAR points based on the return 
value of 1 through 5 or by first, last or multiple returns. Best used for classifying 
vegetation 

• Surface Speckle Filter: This filter classifies LiDAR points by analyzing the percentage of 
neighboring points at the same elevation interval. Best used to remove surface noise 
after bare-earth filtering 

• Classify by LSF Filter: This filter classifies LiDAR points based on the specified LSF color 
value range by band. Best used to isolate ground features based on 3-band spectral 
values 

• Classify by Flight-line filter: This filter classifies LiDAR points by flight-line ID number. It is 
useful in the removal of bad or unnecessary flight-lines 

• LSF color Adjustment: This filter enhances color values in LSF data. Good for enhancing 
shadow areas under vegetation to classify surface points. It will only change the spectral 
values of LSF points in the selected classes 

• High/Low Point Filter: This filter classifies high or low points greater than or less than 
input elevation value for classification of outlier points. Best if used for small projects or 
single files since terrain will likely vary more in larger areas. This filter also could be 
useful on very flat areas too. 

• Model Key Points Filter: Used to “thin” points to the minimum number of points needed 
to describe a surface 

• LAS Output Filter: This function is typically used at the end of a Macro to output the 
filtering to a new LAS file leaving the original LAS file untouched 

• Adjust Z by Flightline Filter: To adjust the Z values of an entire flightline by a constant 
increment 

Building a Filter Macro 
This functionality is only available in the 3D viewer, if the Viewer is invoked by tile. Used to 
build, modify or test a filter a Macro, Click the Macro Options button 

 

Figure 49: VG4D Viewer Filter Toolbar 
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Figure 50: Macro setup 

• In order to start recording a macro, click on Start Recording Filter Macro Steps 
• An existing macro (.mac file) can be loaded using Load Function 
• Save is used for saving the recorded Macro and Clear for clearing the Macro 
• As the macro is being created, the macro can be tested by running it on selected data 

using Run function. The macro will only be run on the visible area in the viewer 
• Once a macro is recorded, a saved macro can be run by clicking on Load and  Run 

Manage filter Macros 
Once Filter Macros have been created and saved in the 3D viewer they must be cataloged in the 
VG4D software. This step is called Managing Filter Macros and is started by:  

• Going to Ground LiDAR Workflow -> Auto Data Classification -> Manage Macros 

• Click on Macro Path to browse for and select the macro file (*.mac) 

• Go to Macro Name and give the macro a name and select Add Macro. The macro will 
appear in the Macro List  

• Repeat for additional macros and click Exit 

• It is recommended that notes are kept for how each macro was used because these 
macros can be reused or modified and reused in future projects 
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Figure 51: Managing Macros 

 

Figure 52: Macro Managing Dialog Box 

Create Filter Polygons 
The creation of filter polygons is a unique feature in VG4D. It allows the user to select very 
specific areas of a project to apply different filter macros. Reference imagery can be displayed 
in the background of the 2D viewer to help in this process. Often times different filter macros 
are needed for urban, forest, mountainous terrains, etc. This step will allow the user to 
efficiently and most effectively classify projects with different terrain types. 
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Create Filter Polygon Using Tile Boundary  
There are two different ways to create a filter polygon; the first is to create it by tile boundary: 

• Ensure that no other icon like tile icon is active 

• Go to Ground LIDAR Workflow -> Auto Data Classification -> Create Classification 
Polygons  

 
Figure 53: Creation of Classification Polygons 

• Select the desired Filter Macro from the Select Filter window. This step must be done 
before the next step 

 
Figure 54: Available Macros for Batch Filter 

• Select the Spatial Select button  in the 2D Viewer Toolbar 

• Click and drag to select a continuous group of tiles or hold the CTRL key down and click 
tile individually 

• Save the filter polygon by going to Project Workflow -> Automatic Filtering -> Save Filter 
Polygons. The software will prompt you to open the new shape file as a layer  
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Figure 55: Create Filter Polygon by Tile Boundary 

Create Filter Polygon using Graphics Tool  
The second way to create a filter polygon is to draw the filter polygon in the 2D Viewer with the 
Graphics tool 

• Go to Ground LiDAR Workflow -> Auto Data Classification -> Create Classification 
Polygons 

• Select the desired Filter Macro from the Select Filter window. This step must be done 
before the next step  

• Select the Graphics tool button   and the Pointer  in the 2D Viewer Toolbar.  

• Draw a polygon by single clicking to place each node and double clicking to complete 
the polygon  

• Save the filter polygon by going to Project Workflow -> Automatic Filtering ->Save Filter 
Polygons. The software will prompt you to open the new shape file as a layer i.e.  a 
shape file 
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Figure 56: Create Filter Polygon by Graphics Tool 

Save Classification/Filter polygon  
• Multiple Filter Polygons can be appended. When saving the multiple filter polygons 

there will be the option of naming a new file or selecting an existing shape file in the 
project directory. If an existing shape file is selected the window will appear asking if the 
shape file should be Overwritten or Appended. 

• One may also import Filter Polygons. For details please refer the help option or the user 
manual 

Run Filter Polygons  
• Highlight the Filter Macro layer in the 2D viewer then go to Ground LiDAR Workflow -> 

Autodata Classification -> Run Classification Polygons. Make sure the correct filter 
macro layer is selected. The message window will appear asking to start filtering. Select 
Yes. This process may often take more time depending upon the polygon and macro.  

• As the tiles are processing, the multiuser capability will allow other instances of the 
software to access the project. The status description will be updated as the VG4D 
Production Manager completes the filtering of all tiles. As the filtering is completed, 
other workstations will be able to access the completed tiles and begin the manual 
editing process. 

• After the tiles are filtered the Attributes Table for the Filter polygon layer (Right Click on 
the filter polygon layer and select Attributes Table) is updated. Figure represents a filter 
polygon that was drawn with the graphics tool. Notice the column “Whole Tile” says 
False. This indicates that the entire tile was not classified, only the area within the Filter 
polygon 

Copyright 2012, AHMCT Research Center, UC Davis



50 
 

 

Figure 57: Attributes of Filter Polygons 

• The “Status” Column indicates whether the tile was completely filtered. A number 0 
indicates the tile completed filtering. If there were a value of -9999 in the “Status” 
column, the filtering was not completed on this tile. 

• If the software is interrupted during filtering, this attribute table will show where the 
filtering left off. Restarting the filter polygon by going to Ground LiDAR Workflow -> 
Autodata Classification -> Run Classification Polygons will read this attribute table first, 
figure out where it stopped and start over from that point. 

Reset Filter Polygons  
• This function will reset the “Status” column in the filter polygon attribute table and 

allow the filter polygon to run from the beginning. 
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Chapter 5: Feature Extraction 
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Feature 
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Batch 
Filtering of 
LAS files

 

In order to understand the process of Feature extraction like Lane Lines, Curb Lines, DTM, and 
Concrete Barriers we have to get acquainted with the Profile Viewer in LiDAR Viewer. 

Profile Viewer  
The VG4D 3D Viewer has the capability of viewing point cloud data as a profile. To open data in 
the Profile Viewer  

• Select the Profile View  button on the VG4D Viewer toolbar  
• The cursor will turn into a crosshair; select the starting point of the desired profile with a 

single left mouse button click  
• Move the cursor to the endpoint of the desired profile and single click  
• Set the width of the profile with a single click  
• The profile view window will open 
• To get out of Profile mode Select the Normal Viewing Mode button  then close out 

the profile window by selecting the close button in the upper right corner  
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Figure 58: Profile View 

• Majority of icons in the profile view are same and have same function as described in 
the Viewer. Instead of the 3D view the profile view shows the cross sectional view. You 
would also observe a limit box in the 3D viewer having a rectangle which moves as you 
move the scene in the profile view which actually shows the active area. One may also 
use the direction arrow keys for navigation. 

 
Figure 59: Limit box in 3D Viewer 

Point Editing Mode 
In the 3D Viewer toolbar select the  , then click on the area where editing will be started. The 
options in dialog box are as explained below: 
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Table 1: Various Function in Point Editing Mode 

Function Defined How to use  
Output Class  Select the layer to edit points 

to  
Pull down and select the 
appropriate class  

Brush Size  Paint brush size  Select the size of the brush. 
Move the brush cursor over 
the points that need to be 
edited 

Class to Protect  Classes can be selected to be 
masked from the editing  

Select the class(s) to be 
protected from editing. This is 
expanded option of “What to 
change” gives more flexibility 
to user to choose what to 
mask and what not to 

Trimmer  No Trimming - This option will  
classify all the points that fall 
inside the edit cursor.  

Select as needed  
 

High Point Trimming - This 
option will automatically 
classify points with high 
elevation that falls inside the 
edit cursor. Very useful to 
remove vegetation in a hilly 
and/or highly vegetated area 
where surface is obscured.  
Low Point Trimming - This 
option will automatically 
classify points with low 
elevation that falls inside the 
edit cursor. Very useful to 
recover surface points in a 
hilly and/or highly vegetated 
area where surface is 
obscured  

Use Mask as Protected Class Check this to include Mask 
class(es) in high/low elevation 
calculation (during high/low 
trimmer) but not to use them 
in classification  

Select as needed  
 

Undo  Set the number points edited 
to be undone for each button 
click  

Click Undo to undo the last 
designated number of points 
edited 
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Feature Extraction 
Feature extraction can be done by two methods: Automatic and Manual Selection of Points in 
VG4D. Let’s take an example of Lane Line Extraction to illustrate the process 

Lane Line Extraction 
VG4D offers very intuitive tools for feature extraction. We will first extract lane Line using 
Automatic Process. 

Automatic Extraction of Lane Line  
• Open the LAS file using Viewer in editing mode 
• Run the following filters: All Reclassify Points and Road surface extraction filter using the 

steps described in previous chapter. You will have the road surface with curb and lane 
lines to begin with this tool 

• Zoom in considerably close to the feature which is lane line. This is solely required in 
order to snap the points on the lane line thereby avoiding any errors 

• Click on Point Editing Mode icon  in the toolbar 

 

Figure 60: Point Editing Dialog Box 
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Figure 61: Lane Line Extraction 

• Specify the Output class where the lane line is required to be moved to. This can be 
further exported as a shape file or a pts/LAS file if required 

• Select Smart Classification and Specify the width (normal values range between 0.1 to 2 
depending upon the accuracy required)  

• Select the Method of extracting the line. In this case we want to extract the Road- White 
Lines (Lane Lines). Hence select Roads- White Lines 

• Since we classified the Road surface to Ground Class, Select Ground Class in Class to 
Consider 

• Select Simple Vector in Digitization Options. Use the options of Top and Bottom when 
curb line is to be extracted 

• Using left click, specify the first point on the Lane line followed by second point. The line 
would automatically track along the entire lane line which can be observed by zoom out 

• Click on Accept to accept the command 
• On Zoom out, you can observe the lane line extended along the entire strip.  

 

Figure 62: Automatic Line Extrapolation of Lane Line 
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Manual Classification of Points  
• Select Point selection command 
• Follow the previous steps as described above except selecting Trimmer instead of Use 

Smart Classification 
• Select ‘None’ option in Trimmer. A square shape cursor would appear in the viewer 

which would be used for picking up the points 
• Specify the class where the desired points are required to be moved to 

 

Figure 63: Black Strip Area in the figure shows the manually selected points 

Editing in the Profile viewer 
• Select the section of the road strip where manual classification of points is required. A 

limit box would be drawn in the selected area in the Viewer and a separate Profile view 
window would be visible 

• In the Profile Viewer, click the Edit Button  . This will bring up the Profile Viewer 
editing tools window  

• Draw the shape as per the requirement of the points to be classified 

 

Figure 64: Manual Selection of points using Line Method in Profile View 

• A dialog box (as seen in figure 65) shows the Edit Mode and output class. Select line 
based edit. Assuming we would require the points above the white line select the option 
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Above Line and specify the name of output class (figure on the next page). You may also 
pan along the points using the interactive arrow buttons.  
 
NOTE: This option would be widely used for selecting concrete barriers, guard rail, sign 
posts and other attributes which do not have any intensity or RGB value for automatic 
selection. Since it is not an automatic process, the user has to manually move the limit 
box along the entire strip for manual selection of points.  
 

• Undo options can be used if reselection is required 

 

Figure 65: Profile View Edit Dialog Box 

• The Point Based option works like the Main View Editing. Select a class, cursor size and 
Hold the left Mouse button and move the cursor over the points that needed to be 
edited. Set the Output class as desired class where the points will be moved.  
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Case Study:  Extraction of Concrete Barriers 
• Open an LAS file having a concrete barrier 
• Click on Profile viewer icon to open the profile view  

 

Figure 66: Limit Box Showing Concrete Barriers 

• You may ensure the limit box is perpendicular to the barrier using On-the-Fly Settings 

icon  
• Use the interactive arrow icons to achieve the desired size of the limit box 

 

Figure 67: On-the-fly settings 
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Figure 68: Limit box for concrete barrier     Figure 69: Arrow keys for aligning and resizing 

• Once the limit box is adjusted, switch to profile view window and click on Point Editing 

Mode icon  
• There are two methods for selecting points: Point based edit and Line based edit 
• Specify the output class where the selected points will be saved/moved to 

 

Figure 70: Manually Selecting the Points of Concrete barrier 

• Point based edit can be used for selecting particular points or when the selection of 
points is very local in the entire LAS file. Figure below shows the points being selected 
and moved to the class Reserved 01. The cursor size can be changed from Small to Large 
depending upon the requirements. 
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Figure 71: Manual selection of points 

• One may also use line method for selection of points as shown below. You need to draw 
a line by left clicking on the points in the profile view and double left click once the 
selection is done.  

                                                                  

Figure 72: Profile View Editing      Figure 73: Classification Selection Tool 
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Figure 74: Feature selection using Line method 

• Since the selected points are moved to the new class, they can be viewed by clicking on 

the  icon in Profile View as well as LiDAR Viewer to view in 2D and 3D respectively  

 

Figure 75: Selected points in separate class 

• Also it is required to select all the points along the barrier by using the arrow keys to 
move the limit box and repeating the above procedure (by either point or line method) 
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Figure 76: Selecting the points by moving the limit box 

• Alternately, the limit box can be increased in size such that the points are classified in 
single process as shown below.  
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Figure 77: Classifying all the points together 

 

Figure 78: Classified points for concrete barrier as seen in LiDAR Viewer of VG4D 
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There are various methods of exporting the data from VG4D: 

Vector Conversion by Tile/File  
• Switch to VG4D Analyzer. Select Ground LiDAR Workflow -> Create Deliverables -> Point 

Export by Tile/File 

 

Figure 79: Point Export by Tile 
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• A dialog box (Vector Conversion by File) opens as shown in Figure 80 

  

Figure 80: Product conversion pull down menu 

• The options explained in the conversion dialog box are are follows: 
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Table 2: Options in Product Conversion Pull-down menu 

Input  
 

Defined  
 

How to use  
 

Convert From  
 

Default if LAS because VG4D 
works directly with the LAS 
format.  

Leave Default  
 

To  Output format both point and 
grid formats available.  

Select the required output 
format. Multiple formats can 
be selected and created at the 
same time.  

Return Information  All Returns, First Returns 
and/or Last Returns can be 
specified for output.  

Select which set of return are 
required for output.  

Classes  List of Classes that can be 
selected for output. 

Select the necessary classes 
for output. If output is to be 
Bare Earth, select the ground 
class only.  

Create Metadata  Two different file formats 
available: XML or ASCII  

Select metadata format if 
required.  

File Prefix  A file prefix can be added to 
the output files.  

Select the relevant prefix as 
needed.  

Output Folder  Where the output files will 
reside.  
 

Select an appropriate file 
location for the output. Make 
sure there is ample space.  

Ignore Points in the Buffered 
Area  

If Tiles were created with 
buffers, this option will 
remove those access points.  

Select as required 

LAS Format  Two LAS output formats are 
available: LAS 1.1 and LAS 1.2  

Select the required LAS 
format.  

Grid Size  If exporting an LAS or ASCII 
Grid, input a grid size.  

Input the specified grid size.  
 

Grid Type  If exporting a grid select the 
appropriate way to define the 
grid for the application using 
the data.  

Select either Lattice (Lower 
Left) or Grid/Mesh (Grid 
Center).  

NOTE: It is also possible to export the output data by a different tile scheme using Vector 
Conversion by Polygon. For details please refer to the manual. 
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Report Generation 

Tile LayoutImportingAnalyzer

Feature 
Extraction

Export

MacrosViewer

Batch 
Filtering of 
LAS files

Report 
Generation

 

Log Report Generator  
• This command generates a report in the form of a text file that logs every event that 

occurs from start to finish in the project production lifecycle. This report is saved as .txt 
file in the project folder. Switch Window to LiDAR Analyzer.  

• Select Ground LiDAR Workflow -> Report Generation -> LOG Report Generator 

 

Figure 81: LOG Report Generator Command 
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Figure 82: A sample report 

Time Report Generator 
Similar to the Log Report, this reporting method has an emphasis on time. The user can select 
the user names, tiles and customize the report as per the requirement. 
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Control Point Quality Report Generator 

Analyzer

Data QA/QC

 

This report is designed to compare the accuracy of the LAS data to a high accuracy ground 
control point file. Click on Ground LiDAR Workflow -> Report Generation -> Quality Report 
Generation 

• Specify the path of LAS files for which QC is required to be done 

 

Figure 83: Quality Report Generation by file 

• In Control Point Settings, specify the path of Control Points file which would be a text 
file. 
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• Search Distance is the distance threshold that the report generator will use from the 
ground control point to find a LiDAR point to compare. Select a search distance that will 
do the best job of finding a point close to the control point. 

• Z Diff. Cut-Off Eliminates the opportunity of the report generator using an outlier point 
in its generation of statistics. Select cut off that will eliminate the chance of outlier being 
used in generating statistics. 

• Select the classes that will be used in the classification. 
• Specify the path of output folder where the generated text file report will be created. 
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Chapter 6: Asset Management 

Analyzer Viewer Asset 
Management

Report 
Generation

 

Asset Management 
• The very first step is to import a strip i.e. a LAS file in Analyzer and create tiles as explained in 

previous chapters 
• Click on Ground LiDAR Workflow - > Perform Digitization/Feature Extraction 

 

Figure 84: Asset Management Command in Analyzer 

• A dialog box appears as shown in figure 85 
• Click on Image folder and browse the path of folder containing all the image files 
• Specify GPS offset and buffer distance if any 
• Click on Add files and specify the path of corresponding LAS files 
• The imported files would be visible in the dialog box as seen in figure 86 
• Click on Ok 
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Figure 85: Image Base Feature Extraction 

 

 

Figure 86: Data imported for Image Based Feature Extraction 
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Figure 87: Imported Image for Feature Extraction 

• A dialog box (Figure 87) opens showing the current image with its image ID and total 
number of images in entire folder 

 

Figure 88: Image viewer for Asset Management 
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• We may use interactive forward and backward keys to switch images as seen in above 
figure 

• One may even click on the number (in this case it is 119/2536) and go to a desired image 
location or image ID.  

• Click on Launch Viewer to see exactly the same part of image in point cloud format (LAS file) 
• Use Normalize Z to Mask Noise option from File -> Preferences for a better view of the points.  

 

Figure 89: LAS file of the same image 

NOTE: The Asset Management links the image files and the LAS files such that the area near the asset 
can be seen along with the asset feature in point cloud format. However one may also put a Redline 
comment to mark the name of asset in the Viewer and save it as a shape file. 

Asset Management in Viewer 
• Asset Management can also be invoked in the Viewer by selecting  File -> Show Asset 

Management Window 

 

Figure 90: Asset Management using LiDAR Viewer 
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• A dialog box opens showing Asset Management Extraction 
• Specify GPS Offset if any 
• Browse the image directory selecting any of the images in the folder 
• Browse the path of Survey Index File (this file is always required for asset management which 

would be generated while scanning the data) 
• Specify the path of Output file which would be a shape file. Entries made in the dialog box would 

be saved as shape file 
• The image would be imported as seen in the figure. Click on Next image or previous images 

depending upon your requirement 
• Click on Launch image to open it in windows image viewer 

 

Figure 91: Asset Management Extraction using LiDAR Viewer 
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Bridge Clearance Measurement 
• One may even use the measure tool  in the Viewer for the same purpose but it does 

not give other details about the bridge clearance 
• Double Click the Left button to mark the two points (top and bottom) of the bridge 
• Click on Asset Management Extraction and select DOT- Bridges from the Feature of 

Interest drop box 
• The Bridge elevation including Latitude, Longitude, and Height would be automatically 

measured and displayed if the data in LAS file and survey index file is correct. You may 
also put other details like Bridge Type, and Bridge Name  
 
NOTE: The Abbreviations at bottom of window in viewer are seen as 

 
where X, Y, Z are the coordinates of the Point. Rn is Return value of the pulse which 
mostly has a value of 1 unless a point is on the vegetation where we have multiple 
returns. I is for the intensity, F stands for file ID, Ht for height. One would also observe 
RGB value if the data is recorded in the RGB form and one may use LSF filter for 
classifying the data as per the RGB 

 

Figure 92: Bridge Clearance measured using Asset Management Toolbox 
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Table 3: Some of the Shortcut Keys in Viewer 

************************************************************************************ 

 

 

Hot Key Description 
F1 Help 
Right Arrow Rotate view clockwise 
Right Arrow + Shift Pan East 
Left Arrow Rotate view counterclockwise 
Left Arrow + Shift Pan West 
Up Arrow Rotates View Down 
Up Arrow + Shift Pan North 
Down Arrow Rotates View Up 
Down Arrow + Shift   
Shift and - Zooms out 
Shift and + Zooms in 
V Increases vertical exaggeration 
Shift + V Decreases Vertical exaggeration 
Z Zoom In 
Shift + Z Zoom Out 
R (or) Shift + R Pans view left (in screen) to make room in right 
U (or) Shift + U Pans view down (in screen) to make room in top 
L (or) Shift + L Pans view right (in screen) to make room in left 
D (or) Shift + D Pans view top (in screen) to make room in down 

E 
Increase elevation angle lighting (ranges from 0 to 90 degrees) 
in TIN mode 

Shift + E 
Decrease elevation angle lighting (ranges from 0 to 90 degrees) 
in TIN mode 

A 
Increase azimuth angle lighting (ranges from 0 to 360 degrees) 
in TIN mode 

Shift + A 
Decrease azimuth angle lighting (ranges from 0 to 360 degrees) 
in TIN mode 

Normal mouse movement Shows point information in status bar 
Right mouse button + 
mouse move 

Distance measure tool, displays the distance in status bar as 
the cursor pans 

Both buttons down Zooms the View in and out 
Mouse Wheel Zoom Data in and out 
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